PyDapi2


NamePyDapi2 JSON
Version 0.1.1 PyPI version JSON
download
home_pagehttps://github.com/dassym/PyDapi2
SummaryThe PyDapi2 library offers a Python implementation of the Dassym API version 2.
upload_time2021-06-11 08:30:51
maintainer
docs_urlNone
authorFabrice Voillat
requires_python>=3.8
license
keywords dassym motor api dapi
VCS
bugtrack_url
requirements No requirements were recorded.
Travis-CI No Travis.
coveralls test coverage No coveralls.
            # PyDapi2
The *PyDapi2* library offers a Python implementation of the Dassym API version 2.

Dassym API version 2 aka **DAPI2** is the application programming interface (API) used to
control Dassym electronic boards.

This library was created to meet the internal needs of Dassym. It is distributed to help 
our partners to implement their own solutions working with Dassym electronic cards.

Version: 0.1.1 (2021-06-11)

This program is free software: you can redistribute it and/or modify 
it under the terms of the **GNU General Public License** as published by 
the Free Software Foundation, either version 3 of the License, or 
(at your option) any later version.

This program is distributed in the hope that it will be useful, 
but WITHOUT ANY WARRANTY; without even the implied warranty of 
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the 
GNU General Public License for more details. 

You can consult the GNU General Public License on <http://www.gnu.org/licenses/gpl-3.0.html>.


## Install

This installs a package that can be used from Python (import dapi2).

To install for all users on the system, administrator rights (root) may be required.

*PyDapi2* library requires [Python](https://www.python.org) 3.8 or later.

### From PyPI

*PyDapi2* can be installed from PyPI:

> python -m pip install PyDapi2

Use `python` or `python3` depending on your system.
Usually `python` on a *Windows* system and `python3` on a *GNU/Linux* system.


### From source

Download the archive from <https://github.com/dassym/PyDapi2/releases>.
Unpack the archive, enter the PyDapi2-x.y.z directory and run:

> python setup.py install 

Use `python` or `python3` depending on your system.
Usually `python` on a *Windows* system and `python3` on a *GNU/Linux* system.




            

Raw data

            {
    "_id": null,
    "home_page": "https://github.com/dassym/PyDapi2",
    "name": "PyDapi2",
    "maintainer": "",
    "docs_url": null,
    "requires_python": ">=3.8",
    "maintainer_email": "",
    "keywords": "Dassym,motor,api,dapi",
    "author": "Fabrice Voillat",
    "author_email": "dev@dassym.com",
    "download_url": "https://files.pythonhosted.org/packages/58/8f/a489917b2f6c9bf805525b251d57bef019b4f75a400c622db5e4635b79dc/PyDapi2-0.1.1.tar.gz",
    "platform": "",
    "description": "# PyDapi2\nThe *PyDapi2* library offers a Python implementation of the Dassym API version 2.\n\nDassym API version 2 aka **DAPI2** is the application programming interface (API) used to\ncontrol Dassym electronic boards.\n\nThis library was created to meet the internal needs of Dassym. It is distributed to help \nour partners to implement their own solutions working with Dassym electronic cards.\n\nVersion: 0.1.1 (2021-06-11)\n\nThis program is free software: you can redistribute it and/or modify \nit under the terms of the **GNU General Public License** as published by \nthe Free Software Foundation, either version 3 of the License, or \n(at your option) any later version.\n\nThis program is distributed in the hope that it will be useful, \nbut WITHOUT ANY WARRANTY; without even the implied warranty of \nMERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the \nGNU General Public License for more details. \n\nYou can consult the GNU General Public License on <http://www.gnu.org/licenses/gpl-3.0.html>.\n\n\n## Install\n\nThis installs a package that can be used from Python (import dapi2).\n\nTo install for all users on the system, administrator rights (root) may be required.\n\n*PyDapi2* library requires [Python](https://www.python.org) 3.8 or later.\n\n### From PyPI\n\n*PyDapi2* can be installed from PyPI:\n\n> python -m pip install PyDapi2\n\nUse `python` or `python3` depending on your system.\nUsually `python` on a *Windows* system and `python3` on a *GNU/Linux* system.\n\n\n### From source\n\nDownload the archive from <https://github.com/dassym/PyDapi2/releases>.\nUnpack the archive, enter the PyDapi2-x.y.z directory and run:\n\n> python setup.py install \n\nUse `python` or `python3` depending on your system.\nUsually `python` on a *Windows* system and `python3` on a *GNU/Linux* system.\n\n\n\n",
    "bugtrack_url": null,
    "license": "",
    "summary": "The PyDapi2 library offers a Python implementation of the Dassym API version 2.",
    "version": "0.1.1",
    "split_keywords": [
        "dassym",
        "motor",
        "api",
        "dapi"
    ],
    "urls": [
        {
            "comment_text": "",
            "digests": {
                "md5": "ec93d0fe23bcecf7ae2a514e07690fc9",
                "sha256": "3bf68894fe254b5af7b784b470db45ad2a6b11febac68a1a5422cdcaeba63c4f"
            },
            "downloads": -1,
            "filename": "PyDapi2-0.1.1-py3-none-any.whl",
            "has_sig": false,
            "md5_digest": "ec93d0fe23bcecf7ae2a514e07690fc9",
            "packagetype": "bdist_wheel",
            "python_version": "py3",
            "requires_python": ">=3.8",
            "size": 61374,
            "upload_time": "2021-06-11T08:30:50",
            "upload_time_iso_8601": "2021-06-11T08:30:50.422686Z",
            "url": "https://files.pythonhosted.org/packages/7c/47/0cd4f2ec8f3b07a2a49c80be944df094f3b1040966d90c5f11efb44d55bb/PyDapi2-0.1.1-py3-none-any.whl",
            "yanked": false,
            "yanked_reason": null
        },
        {
            "comment_text": "",
            "digests": {
                "md5": "9f113072afb021be4f0c09458bac2a5f",
                "sha256": "173fb2b2b36d9cea5e1cd6d211a88a0644aa19f3d521e1fa91de681c97ae18cc"
            },
            "downloads": -1,
            "filename": "PyDapi2-0.1.1.tar.gz",
            "has_sig": false,
            "md5_digest": "9f113072afb021be4f0c09458bac2a5f",
            "packagetype": "sdist",
            "python_version": "source",
            "requires_python": ">=3.8",
            "size": 47124,
            "upload_time": "2021-06-11T08:30:51",
            "upload_time_iso_8601": "2021-06-11T08:30:51.537840Z",
            "url": "https://files.pythonhosted.org/packages/58/8f/a489917b2f6c9bf805525b251d57bef019b4f75a400c622db5e4635b79dc/PyDapi2-0.1.1.tar.gz",
            "yanked": false,
            "yanked_reason": null
        }
    ],
    "upload_time": "2021-06-11 08:30:51",
    "github": true,
    "gitlab": false,
    "bitbucket": false,
    "github_user": null,
    "github_project": "dassym",
    "error": "Could not fetch GitHub repository",
    "lcname": "pydapi2"
}
        
Elapsed time: 0.35628s