# Salt Extension for Nix
Salt Extension for interacting with Nix
## Security
If you discover a security vulnerability, please refer
to [Salt's security guide][security].
## User Documentation
For setup and usage instructions, please refer to the
[User Documentation][docs].
## Contributing
The saltext-nix project welcomes contributions from anyone!
The [Salt Extensions guide][salt-extensions-guide] provides comprehensive instructions on all aspects
of Salt extension development, including [writing tests][writing-tests], [running tests][running-tests],
[writing documentation][writing-docs] and [rendering the docs][rendering-docs].
### Quickstart
To get started contributing, first clone this repository (or your fork):
```bash
# Clone the repo
git clone --origin upstream git@github.com:salt-extensions/saltext-nix.git
# Change to the repo dir
cd saltext-nix
```
#### Automatic
If you have installed [direnv][direnv], allowing the project's `.envrc` ensures
a proper development environment is present and the virtual environment is active.
Without `direnv`, you can still run the automation explicitly:
```bash
python3 tools/initialize.py
source .venv/bin/activate
```
#### Manual
Please follow the [first steps][first-steps], skipping the repository initialization and first commit.
### Pull request
Always make changes in a feature branch:
```bash
git switch -c my-feature-branch
```
To [submit a Pull Request][submitting-pr], you'll need a fork of this repository in
your own GitHub account. If you followed the instructions above,
set your fork as the `origin` remote now:
```bash
git remote add origin git@github.com:<your_fork>.git
```
Ensure you followed the [first steps][first-steps] and commit your changes, fixing any
failing `pre-commit` hooks. Then push the feature branch to your fork and submit a PR.
### Ways to contribute
Contributions come in many forms, and they’re all valuable! Here are some ways you can help
without writing code:
* **Documentation**: Especially examples showing how to use this project
to solve specific problems.
* **Triaging issues**: Help manage [issues][issues] and participate in [discussions][discussions].
* **Reviewing [Pull Requests][PRs]**: We especially appreciate reviews using [Conventional Comments][comments].
You can also contribute by:
* Writing blog posts
* Sharing your experiences using Salt + Nix
on social media
* Giving talks at conferences
* Publishing videos
* Engaging in IRC, Discord or email groups
Any of these things are super valuable to our community, and we sincerely
appreciate every contribution!
[security]: https://github.com/saltstack/salt/blob/master/SECURITY.md
[salt-extensions-guide]: https://salt-extensions.github.io/salt-extension-copier/
[writing-tests]: https://salt-extensions.github.io/salt-extension-copier/topics/testing/writing.html
[running-tests]: https://salt-extensions.github.io/salt-extension-copier/topics/testing/running.html
[writing-docs]: https://salt-extensions.github.io/salt-extension-copier/topics/documenting/writing.html
[rendering-docs]: https://salt-extensions.github.io/salt-extension-copier/topics/documenting/building.html
[first-steps]: https://salt-extensions.github.io/salt-extension-copier/topics/creation.html#initialize-the-python-virtual-environment
[submitting-pr]: https://docs.github.com/en/pull-requests/collaborating-with-pull-requests/proposing-changes-to-your-work-with-pull-requests/creating-a-pull-request-from-a-fork
[direnv]: https://direnv.net
[issues]: https://github.com/salt-extensions/saltext-nix/issues
[PRs]: https://github.com/salt-extensions/saltext-nix/pulls
[discussions]: https://github.com/salt-extensions/saltext-nix/discussions
[comments]: https://conventionalcomments.org/
[docs]: https://salt-extensions.github.io/saltext-nix/
Raw data
{
"_id": null,
"home_page": null,
"name": "saltext.nix",
"maintainer": null,
"docs_url": null,
"requires_python": ">=3.8",
"maintainer_email": null,
"keywords": "salt-extension",
"author": null,
"author_email": "jeanluc <lkubb@protonmail.com>",
"download_url": "https://files.pythonhosted.org/packages/b3/42/67f7c549644fff57ce458f8da5d0733230012491ac63aced2866db13108c/saltext_nix-1.0.0.tar.gz",
"platform": "any",
"description": "# Salt Extension for Nix\n\nSalt Extension for interacting with Nix\n\n## Security\n\nIf you discover a security vulnerability, please refer\nto [Salt's security guide][security].\n\n## User Documentation\n\nFor setup and usage instructions, please refer to the\n[User Documentation][docs].\n\n## Contributing\n\nThe saltext-nix project welcomes contributions from anyone!\n\nThe [Salt Extensions guide][salt-extensions-guide] provides comprehensive instructions on all aspects\nof Salt extension development, including [writing tests][writing-tests], [running tests][running-tests],\n[writing documentation][writing-docs] and [rendering the docs][rendering-docs].\n\n### Quickstart\n\nTo get started contributing, first clone this repository (or your fork):\n\n```bash\n# Clone the repo\ngit clone --origin upstream git@github.com:salt-extensions/saltext-nix.git\n\n# Change to the repo dir\ncd saltext-nix\n```\n\n#### Automatic\nIf you have installed [direnv][direnv], allowing the project's `.envrc` ensures\na proper development environment is present and the virtual environment is active.\n\nWithout `direnv`, you can still run the automation explicitly:\n\n```bash\npython3 tools/initialize.py\nsource .venv/bin/activate\n```\n\n#### Manual\nPlease follow the [first steps][first-steps], skipping the repository initialization and first commit.\n\n### Pull request\n\nAlways make changes in a feature branch:\n\n```bash\ngit switch -c my-feature-branch\n```\n\nTo [submit a Pull Request][submitting-pr], you'll need a fork of this repository in\nyour own GitHub account. If you followed the instructions above,\nset your fork as the `origin` remote now:\n\n```bash\ngit remote add origin git@github.com:<your_fork>.git\n```\n\nEnsure you followed the [first steps][first-steps] and commit your changes, fixing any\nfailing `pre-commit` hooks. Then push the feature branch to your fork and submit a PR.\n\n### Ways to contribute\n\nContributions come in many forms, and they\u2019re all valuable! Here are some ways you can help\nwithout writing code:\n\n* **Documentation**: Especially examples showing how to use this project\n to solve specific problems.\n* **Triaging issues**: Help manage [issues][issues] and participate in [discussions][discussions].\n* **Reviewing [Pull Requests][PRs]**: We especially appreciate reviews using [Conventional Comments][comments].\n\nYou can also contribute by:\n\n* Writing blog posts\n* Sharing your experiences using Salt + Nix\n on social media\n* Giving talks at conferences\n* Publishing videos\n* Engaging in IRC, Discord or email groups\n\nAny of these things are super valuable to our community, and we sincerely\nappreciate every contribution!\n\n[security]: https://github.com/saltstack/salt/blob/master/SECURITY.md\n[salt-extensions-guide]: https://salt-extensions.github.io/salt-extension-copier/\n[writing-tests]: https://salt-extensions.github.io/salt-extension-copier/topics/testing/writing.html\n[running-tests]: https://salt-extensions.github.io/salt-extension-copier/topics/testing/running.html\n[writing-docs]: https://salt-extensions.github.io/salt-extension-copier/topics/documenting/writing.html\n[rendering-docs]: https://salt-extensions.github.io/salt-extension-copier/topics/documenting/building.html\n[first-steps]: https://salt-extensions.github.io/salt-extension-copier/topics/creation.html#initialize-the-python-virtual-environment\n[submitting-pr]: https://docs.github.com/en/pull-requests/collaborating-with-pull-requests/proposing-changes-to-your-work-with-pull-requests/creating-a-pull-request-from-a-fork\n[direnv]: https://direnv.net\n[issues]: https://github.com/salt-extensions/saltext-nix/issues\n[PRs]: https://github.com/salt-extensions/saltext-nix/pulls\n[discussions]: https://github.com/salt-extensions/saltext-nix/discussions\n[comments]: https://conventionalcomments.org/\n[docs]: https://salt-extensions.github.io/saltext-nix/\n",
"bugtrack_url": null,
"license": "Apache Software License",
"summary": "Salt Extension for interacting with Nix",
"version": "1.0.0",
"project_urls": {
"Documentation": "https://salt-extensions.github.io/saltext-nix/",
"Homepage": "https://github.com/salt-extensions/saltext-nix",
"Source": "https://github.com/salt-extensions/saltext-nix",
"Tracker": "https://github.com/salt-extensions/saltext-nix/issues"
},
"split_keywords": [
"salt-extension"
],
"urls": [
{
"comment_text": "",
"digests": {
"blake2b_256": "76e9ac11a7fe9a5076d50897d3a7528d21dfe27f84d243b8d4ce32c4d22f0008",
"md5": "70f2e893a9f47d9f3fcc3a7e5d44b32a",
"sha256": "73d13a0d19f72bed7c59821c7984000c7d6c126e7a1ca6e806a94be7b63437d2"
},
"downloads": -1,
"filename": "saltext.nix-1.0.0-py2.py3-none-any.whl",
"has_sig": false,
"md5_digest": "70f2e893a9f47d9f3fcc3a7e5d44b32a",
"packagetype": "bdist_wheel",
"python_version": "py2.py3",
"requires_python": ">=3.8",
"size": 11639,
"upload_time": "2024-09-28T09:26:39",
"upload_time_iso_8601": "2024-09-28T09:26:39.142375Z",
"url": "https://files.pythonhosted.org/packages/76/e9/ac11a7fe9a5076d50897d3a7528d21dfe27f84d243b8d4ce32c4d22f0008/saltext.nix-1.0.0-py2.py3-none-any.whl",
"yanked": false,
"yanked_reason": null
},
{
"comment_text": "",
"digests": {
"blake2b_256": "b34267f7c549644fff57ce458f8da5d0733230012491ac63aced2866db13108c",
"md5": "185dbfb7a2f4000404d9f8b324e1799d",
"sha256": "c7ceae9ab0eec24aa1fa2934d19aa0097c26acb75a15a7d47776a462d2b59c62"
},
"downloads": -1,
"filename": "saltext_nix-1.0.0.tar.gz",
"has_sig": false,
"md5_digest": "185dbfb7a2f4000404d9f8b324e1799d",
"packagetype": "sdist",
"python_version": "source",
"requires_python": ">=3.8",
"size": 49659,
"upload_time": "2024-09-28T09:26:40",
"upload_time_iso_8601": "2024-09-28T09:26:40.909309Z",
"url": "https://files.pythonhosted.org/packages/b3/42/67f7c549644fff57ce458f8da5d0733230012491ac63aced2866db13108c/saltext_nix-1.0.0.tar.gz",
"yanked": false,
"yanked_reason": null
}
],
"upload_time": "2024-09-28 09:26:40",
"github": true,
"gitlab": false,
"bitbucket": false,
"codeberg": false,
"github_user": "salt-extensions",
"github_project": "saltext-nix",
"travis_ci": false,
"coveralls": true,
"github_actions": true,
"lcname": "saltext.nix"
}